Monkey Labs Monkey Labs/ status History
Major

Geyser — major outage

Ot90nfRLOy1Z0QpyZsoBP resolved since Jul 19, 2026 5:40 AM UTC detected automatically
affected   Monkey LabsSessions.ggBackendGame ServicesMinecraftGeyser
Updates
resolved 5:56 AM

Our monitors no longer detect an issue affecting Geyser. Service has returned to normal.

investigating 5:40 AM

We're investigating a major issue affecting Geyser. Some requests may be failing. We'll post an update as soon as we know more.